online faq recherche accueil
  

FORUM JudgeHype

»

DiabloII et LoD

»

Est-il possible de retrograder la version du jeu ? [ne marche pas ]

 

Il y a 76 utilisateurs connus et inconnus. Pour voir la liste des connectés connus, cliquez ici

 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Est-il possible de retrograder la version du jeu ? [ne marche pas ]

n°4815364
Personnage
Posté le 08-02-2013 à 18:56:30  profilanswer
 

Bonjour, bonsoir.  
 
Je me demandais s'il était possible de retrograder la version de mon jeu (par exemple revenir en 1.00 ou 1.09) sans avoir à réinstaller complètement le soft ?  
 
Serait-il par ailleurs possible aussi de jouer en TCP/IP avec un ami qui possèderait la même version du jeu ?  
 
Merci d'avance et bonne soirée.


Message édité par Personnage le 08-02-2013 à 23:48:57
mood
Publicité
Posté le 08-02-2013 à 18:56:30  profilanswer
 

n°4815365
Kyjja
Noir sur Noir.
Posté le 08-02-2013 à 19:23:10  profilanswer
 

Oui, c'est possible (cf signature de Constance).


---------------
Diablo 1 / Diablo 2 : Guides, FAQ, outils...
Topics divers : Dépensez vos budgets : le topic hardware de JH | Le topic du calcul partagé (Boinc, Folding@home, SETI...) | Ma config | Optimiser son PC | Mon 5∞px de prolétaire | PC JEUX vainqueur du sapin | WoT | WoTstats
Tu peux te calmer qd même. Si c'est pour foutre la merde, on peut se passer de toi. LHF, le 24/02/2013 | Kyjja la poisse du matos ! CdE, le 24/06/2013 | Putain ce gay de gayjja chope le 6666 et même pas il s'en rend compte putain de sous-race ! Makou, le 17/09/2013 sur sa TL :happy: | Kyjja, l'homme qui trouve les mots pour te faire utiliser ta thune. Papa, le 05/02/2014 | Kyjja, l'homme pour qui tout throttle. Macuser, le 01/07/2014 | Kyjja :o C'est un signe :o Achète :o Il a une mobale vivante :o Witchie, le 14/07/2014 | Le Chuck Norris de la virilité, sisi Makou, le 27/11/2014
n°4815366
Constance
[ms]Modo Maudit®
Profil : Modérateur
Posté le 08-02-2013 à 19:40:02  profilanswer
 

Y a rien dans ma signature [:constance:5]
Mais sinon c'est dans la FAQ, je crois.

n°4815367
Witchblade
[ms]Membre Maudit®
Posté le 08-02-2013 à 20:18:36  profilanswer
 

Ou dans la sign de Constance.


---------------
[:witchblade:6][:witchblade:8][:witchblade:9][:witchblade:3]
"Si tu fonces pas, tu te fais Ninja" / "To troll or to be troll, there is nothing different"©Geoff
n°4815368
Personnage
Posté le 08-02-2013 à 20:39:38  profilanswer
 

Je vous remercie, c'est exactement ce dont j'avais besoin.  
 
Bonne soirée.

n°4815369
Personnage
Posté le 08-02-2013 à 23:29:41  profilanswer
 

Le double post est proscrit mais j'ai peur de passer inaperçu avec un édit, donc je me permets cet écart.  
 
J'ai un souci inhérent au cd.  
En effet une fois avoir réinstalle l'exe D2C1.0, lorsque je le lance il me demande d'insérer le CD.  
Or même en insérant le CD de ma version de D2 (qui installe le jeu automatiquement en 1.12), le jeu me demande sans cesse d'insérer le CD.  
 
Il semblerait qu'il ne reconnaisse donc pas ce CD plus récent, y a t-il une solution viable, comme un patch no cd par exemple ?

n°4815370
Witchblade
[ms]Membre Maudit®
Posté le 09-02-2013 à 03:37:15  profilanswer
 

Oui, normal, le CD Check a été supprimé à partir de la 1.12.
Il te faudra le No-CD correspondant ou émuler via un soft comme Daemon Tools (perso jamais réussi avec ce jeu :??: )


---------------
[:witchblade:6][:witchblade:8][:witchblade:9][:witchblade:3]
"Si tu fonces pas, tu te fais Ninja" / "To troll or to be troll, there is nothing different"©Geoff
n°4815371
Constance
[ms]Modo Maudit®
Profil : Modérateur
Posté le 09-02-2013 à 11:50:13  profilanswer
 

Hmm dans le temps (quand je tournais sous 98 :ack: ) avec Daemon Tools il suffisait d'activer l'émulation SecuROM pour D2.
Mais le fait que la 1.00 demande systématiquement le CD même s'il est présent, ça pourrait être une incompatibilité liée à un OS plus récent, éventuellement…
On peut toujours tenter de coller un patch intermédiaire, comme le 1.09 mentionné initialement.


Message édité par Constance le 09-02-2013 à 11:50:55
n°4815372
Juju Dredd
Posté le 10-02-2013 à 02:13:57  profilanswer
 

Bonjour,
 
Les premières versions de Diablo II (avant la sortie de LoD) ne cherchent pas le CD du jeu dans tous les lecteurs du PC mais seulement dans celui qui lui est indiqué dans la base des registres.
 
Avec regedit.exe, essaie d'aller voir les clefs dans "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Blizzard Entertainment\Diablo II" (sans le "Wow6432Node" si ton OS n'est pas 64-bits) il y a sans doute une clef qui correspond.

n°4815374
Personnage
Posté le 10-02-2013 à 12:44:34  profilanswer
 

Les seules clés présentes sont le chemin vers le game.exe, l'install et l'uninstall, ce qui me semble assez peu intéressant de notre point de vue.  
 
 

Citation :

Hmm dans le temps (quand je tournais sous 98 :ack: ) avec Daemon Tools il suffisait d'activer l'émulation SecuROM pour D2.
Mais le fait que la 1.00 demande systématiquement le CD même s'il est présent, ça pourrait être une incompatibilité liée à un OS plus récent, éventuellement…
On peut toujours tenter de coller un patch intermédiaire, comme le 1.09 mentionné initialement.


 
En effet, je tourne sous seven 64 bits, je pense que l'incompatibilité vient de là, et probablement aussi du fait que mon CD boot de base en 1.12 comme l'a souligné Witchblade.  
 
Tu penses qu'un jeu en 1.09 règlerai le souci ?
 
- dans tous les cas merci à vous pour les réponses -


Message édité par Personnage le 10-02-2013 à 12:44:53
n°4815375
Constance
[ms]Modo Maudit®
Profil : Modérateur
Posté le 10-02-2013 à 14:08:56  profilanswer
 

En tout cas je dirais que ça se tente :p
Mais tu as bien des CD, ce ne sont pas juste les fichiers d'install de la version téléchargeable ?

n°4815376
Personnage
Posté le 10-02-2013 à 15:32:58  profilanswer
 

Mes CD de D2 ont quelques années, ils installent le jeu directement en 1.12 en fait.  
 
Du coup quand j'ai fait la manip pour mettre le jeu en 1.0 (supprimer les .exe, les dll & le patch_d2.mpq puis c/c le contenu de l'archive), et que je lance le jeu, il me demande le cd, sauf que mon cd actuel ne semble pas être reconnu.  
Je ne sais pas si ça vient du fait qu'il soit en 1.12 ou si c'est à cause de mon OS trop récent.  
 
Est-ce que tu as une archive comme celles de ton site qui permettrait de rétrograder le jeu en 1.09, afin que je teste ?


Message édité par Personnage le 10-02-2013 à 17:49:02
n°4815377
Constance
[ms]Modo Maudit®
Profil : Modérateur
Posté le 10-02-2013 à 16:43:16  profilanswer
 

Ouaip, il doit y avoir ce qu'il faut dans cette archive : http://www.mediafire.com/?hcmninhmj3a

n°4815378
Juju Dredd
Posté le 10-02-2013 à 20:26:49  profilanswer
 

Je viens de regarder sur mon vieux PC, la liste des clefs crées par un installeur plus ancien :
DiabloIICD
InstallPath
Program
Save Path
SmallInstall
 
DiabloIICD de type "REG_SZ" vaut chez moi "F:", tu peux essayer de rajouter cette clef en adaptant sa valeur à ton PC.
SmallInstall est de type REG_DWORD et vaut 0x00 (0 en hexa en fait), tu peux toujours essayer de le rajouter aussi.

n°4815379
Personnage
Posté le 11-02-2013 à 16:35:08  profilanswer
 

Après installation de la 1.09, le souci est exactement le même, avec l'inlassable demande d'insérer le disque plus ce petit message d'erreur : http://image.noelshack.com/fichiers/2013/07/1360596690-unable-blabla.png
 
 
Juju => Les clés restent les mêmes quelle que soit la version que j'installe.

n°4815380
Constance
[ms]Modo Maudit®
Profil : Modérateur
Posté le 12-02-2013 à 05:11:18  profilanswer
 

Hmm je viens de restaurer les fichiers de la 1.09d et en tentant d'exécuter le jeu, je suis directement confronté à ce message :
http://uppix.net/7/e/b/4611c1c88210b7e8889937743f798.png
Tu ne l'as pas eu ?
En tout cas ça semble clair que les anciennes versions ne marchent pas ou mal sous Windows 7 x64…

n°4815381
Witchblade
[ms]Membre Maudit®
Posté le 12-02-2013 à 07:54:21  profilanswer
 

J'ai joué sans problème avec 1.09d/1.10s/1.11b/1.12, perso :ack:

 

(Digital Download, fichier magique quand besoin)


Message édité par Witchblade le 12-02-2013 à 07:55:56

---------------
[:witchblade:6][:witchblade:8][:witchblade:9][:witchblade:3]
"Si tu fonces pas, tu te fais Ninja" / "To troll or to be troll, there is nothing different"©Geoff
n°4815382
Constance
[ms]Modo Maudit®
Profil : Modérateur
Posté le 12-02-2013 à 07:55:02  profilanswer
 

"fichier magique" ? :hmm:

n°4815383
Witchblade
[ms]Membre Maudit®
Posté le 12-02-2013 à 07:58:44  profilanswer
 

Pas envie de me taper le CD  avec <1.12 :o


---------------
[:witchblade:6][:witchblade:8][:witchblade:9][:witchblade:3]
"Si tu fonces pas, tu te fais Ninja" / "To troll or to be troll, there is nothing different"©Geoff
n°4815384
Personnage
Posté le 12-02-2013 à 12:43:09  profilanswer
 

Nope Constance, j'ai pas eu ce message d'erreur, juste celui cité plus haut & la demande d'insérer le disque.  
Mais je pense que l'idée est là, il y a clairement un souci de compatibilité.  
 
C'est quoi ce fichier magique ?  
 
 
PS : Ça n'a rien à voir mais j'allais pas ouvrir 30 sujets, donc je cherchais un raccourci qui existait quand je jouais à D2 y a vraiment longtemps, qui permettait de voir en permanence tous les objets par terre sans avoir à appuyer sur alt ou à passer le curseur dessus. Je me rappelle qu'on pouvait aussi cacher les objets normaux je crois mais je sais pas si je confonds avec Titan Quest là.


Message édité par Personnage le 12-02-2013 à 12:43:31

Aller à :
Ajouter une réponse
  

FORUM JudgeHype

»

DiabloII et LoD

»

Est-il possible de retrograder la version du jeu ? [ne marche pas ]